ClickHouse Cloud permissions errors
Resolved·Partial outage

After investigation and identification, this incident has been resolved. As noted previously, this new permissions checking in ClickHouse 23.9 is a better and more proper method of ensuring grants on these uses of asynchronous inserts and dictionaries. In order to properly apply these grants, please refer to the following ClickHouse Knowledge Base (KB) article:https://clickhouse.com/docs/knowledgebase/ingest-failures-23-9-release

We apologize for any interruption from this change in behavior, as it should have been better communicated prior to the release. If you require any additional assistance with updating your user grants in ClickHouse Cloud, please reach out to ClickHouse Support via a new case or chat:https://clickhouse.cloud/support

Fri, Nov 17, 2023, 08:06 PM
(1 year ago)
·
Affected components
Updates

Resolved

After investigation and identification, this incident has been resolved. As noted previously, this new permissions checking in ClickHouse 23.9 is a better and more proper method of ensuring grants on these uses of asynchronous inserts and dictionaries. In order to properly apply these grants, please refer to the following ClickHouse Knowledge Base (KB) article:https://clickhouse.com/docs/knowledgebase/ingest-failures-23-9-release

We apologize for any interruption from this change in behavior, as it should have been better communicated prior to the release. If you require any additional assistance with updating your user grants in ClickHouse Cloud, please reach out to ClickHouse Support via a new case or chat:https://clickhouse.cloud/support

Fri, Nov 17, 2023, 08:06 PM

Monitoring

As noted, the workaround for this new behavior in ClickHouse 23.9 is described in more detail in the following KB article:https://clickhouse.com/docs/knowledgebase/ingest-failures-23-9-release

If you require any additional assistance in updating your user grants in ClickHouse Cloud, please reach out to ClickHouse Support via a new case or chat:https://clickhouse.cloud/support

Fri, Nov 17, 2023, 07:57 PM

Identified

The root cause of these permissions errors has been identified and is due to more strict checking of grants for asynchronous inserts and dictionaries in the 23.9 release. If you are using a non-default user with limited permissions to perform asynchronous inserts or dictionary creation, you must apply additional grants to this user.

The workaround for this issue is described in more detail in the following KB article: https://clickhouse.com/docs/knowledgebase/ingest-failures-23-9-release

Fri, Nov 17, 2023, 07:53 PM

Investigating

ClickHouse has been alerted to user-level database 4xx permissions errors in ClickHouse Cloud and is actively investigating the issue

Fri, Nov 17, 2023, 06:18 PM(1 hour earlier)
Powered by

Availability metrics are reported at an aggregate level across all tiers and error types.
Individual customer availability may vary depending on their workload, autoscaling settings and API features in use.